Post

4 followers Follow
0
Avatar

iOS app crashing

My app was working perfectly fine until I upload a new build to Apple. Ive recreated a new build and submitted it as an update to Apple. What could have caused this issue. No settings were changed, just created a new build. I'm at a lost because a Mag+ representative has tested the app and didn't not have this issue. If the app is already installed or newly downloaded, it crashes upon opening. I tested the build before submitting it and it did not crash. As I said now I've created yet another build and submitted to Apple, but its in the waiting on review stage. At this point I have end users complaining about this and my stats are taking a hit. Any suggestions? Thanks in advanced.

-Chanel

CHANEL CHERIE FLOWERS

Please sign in to leave a comment.

8 comments

0
Avatar

Hi Chanel,
I'm sorry you're having some issues with crashing, I cannot seem to replicate any crashes either upon downloading your app and a couple issues. Is there a specific issue that you are launching causing crashes? What type of device are you using for testing?

Mike Rettew 0 votes
0
Avatar

Mike thanks for replying. I've tried on iPhone 6, iPhone 5, iPhone 5c, all have the current updated iOS 8.4. The app crashes as soon as it is opened. It never reaches the splash screen, it never completely opens.

CHANEL CHERIE FLOWERS 0 votes
0
Avatar

Hi Chanel,
I ended up testing on iPad first and didn't find any problems, but then I loaded your live app to my iPhone 6 and see that crash you are referring to. I then generated a new build and loaded it to the same phone and it no longer crashes so I believe there could be a problem with your last iPhone build. Try generating a new build and install a test version to your iPhone devices and see if that helps.

I'm also not sure if this is the case but I would recommend uploading flattened Launch Page images (all of them) rather than the transparent logo as this could be causing problems on your iPhone splash screens once it gets to Apple and goes live.

Mike Rettew 0 votes
0
Avatar

I have the same problem too. My last build was working fine until I made some change on the new build, but not with the settings. The new build exports and is download totally perfectly but it cannot be open on magplus reviewer on ipad or iphone, it just jumps out to home screen. Any suggestion please? Thanks.

My Dinh 0 votes
0
Avatar

Ah, and I try generating a new one but it doesnt work, neither. Please help :( Thanks in advanced!

My Dinh 0 votes
0
Avatar

Hi Mike I've uploaded a new build to Apple, just still waiting. On the flip side I can't get it to install on any of the iPhones I have. I had this problem when I first started. It continues to fail on install. I'll continue to troubleshoot until I get frustrated or get it resolved. Thanks for your assistance.

CHANEL CHERIE FLOWERS 0 votes
1
Avatar

Hello!
If you're still having trouble with MIBs crashing your Reviewer app it could be the content of the MIB or maybe the device just needs to be restarted. If you'd like to send me your MIB file I can take a look. You could also try deleting the Reviewer app entirely and reinstalling it to see if that helps.

@Chanel, are you receiving any type of error message when you attempt to install your app on the iPhone? Have you added that iPhone's UDID to your AdHoc Provisioning Profile?
https://support.magplus.com/hc/en-us/articles/203808078

Regards,
Mike Rettew
Mag+ Support Team

Mike Rettew 1 vote