Post

2 followers Follow
0
Avatar

Language not changing in iOS, urgent!

Hi everyone,

I have chosen Russian in the language field in Admin panel and I have uploaded ru.strings file to the customisation panel, but the language is still english, when I test the app. I need to submit my app asap, please help. Android works well in russian.

ru.strings is Attached

Denis Beklarov

Please sign in to leave a comment.

7 comments

0
Avatar

Hi Denis,

Have you changed the LOCAL INDENTIFIER in strings file to Russian. I do not what the code is, but would expect it to be ru.

Maarten

Maarten Gajentaan 0 votes
Comment actions Permalink
0
Avatar

in the englisch template LOCAL IDENTIFIER is  

"LOCALE_IDENTIFIER" = "en";

Maybe I should change it to

"LOCAL_IDENTIFIER" = "ru"; 

but not 

"LOCALE_IDENTIFIER" = "ru";

(localE seems weird to me)

?

Denis Beklarov 0 votes
Comment actions Permalink
0
Avatar

Denis,

I took a look at your strings file and your app and it looks like it is displaying the proper language now.  Are you still having any trouble?

Regards,

Mike Rettew 

Mag+ Support Team

Mike Rettew 0 votes
Comment actions Permalink
0
Avatar

I selected English as a language, but edited en.strings with Russian translations, so the app language is still English, but it displays Russian strings in it. I believe it is ok, or should I make it Russian as default? Apple reviewed it successfully. 

Denis Beklarov 0 votes
Comment actions Permalink
0
Avatar

Denis,

If you are referring to the Internationalization setting on your Publish site, this setting is now obsolete as your language is strictly driven by your stings file.  You should be all set.

Regards,

Mike Rettew 

Mag+ Support Team

Mike Rettew 0 votes
Comment actions Permalink