Post

1 follower Follow
0
Avatar

Urgent! App crashes in reviewer when taping on specific jumplinks

Hi Magplus

I have a deliverence this Wednesday, and the app (4.2) version crashes on a specific jumplink pointing to another vertival in the app when viewed in the reviver.

It is only one specific jumplink the other ones works fine.

Is it a reviewer mistake? I can´t deliver the app when it crashes.

Please help.

 

Kinr regards

 

Vicky

Vicky Juel Andersen

Please sign in to leave a comment.

7 comments

0
Avatar

Hi Vicky,

Sorry for your trouble. This is a hard one to solve without seeing the actual MIB.

  • Make sure that the URL is entered correctly and that you have selected it to be a jump link.

  • Make sure that the object you are jumping to does actually exist.

If these suggestions does not help you, please send us the MIB with instructions on how to replicate the problem (where the link is, where it should go etc.) and we might be able to figure out what is going on.

Best regards,

Anders

Anders Odevik 0 votes
0
Avatar

HI Anders,

 

I tried different methods to resolve the issue with the jumplink, do you think the problem is there because the jumplink goes to a page with a video element in loop?

Just thought it might be that...

 

Kind regards

 

Vicky

 

Vicky Juel Andersen 0 votes
0
Avatar

It shouldn't be that. Are you linking to the vertical ID or to an object ID within a vertical? Make sure not to link to an object that is not located on the A or B-layers. Also make sure that the object is not a hotspot or media.

Regards,

Anders

Anders Odevik 0 votes
0
Avatar

HI Anders,

 

I am linking to a vertical ID.

I have desidet to take out the jumplink for now.

I am experiensing that some pages are lagging when swiping between pages.

The lagging occurs between verticals with several pages, incl video in load. (inline movie)

What can I do to, hope you can help

 

Regards Vicky

 

 

Vicky Juel Andersen 0 votes
0
Avatar

Hi Anders,

All the videos are play "in view", and I am using Handbreake for all videos, they are 1,3 to 3,5 MB in size. So they are small.

Please note that I have 3 covers with inline video side by side each other in the beginning of the app. That might also be the reason to the crashing.

I have discovered that if I unclick the "Auto start" the pages are not lagging anymore when swiping between pages.

It is not exactly the look I wanted. But much better then having an app that crashes...

 

Thank you

 

 

 

 

Vicky Juel Andersen 0 votes
0
Avatar

Vicky,

I know with all the interactive design that we all can do now, that as designers we want to stretch the boundaries. But in my opinion, I would think that it is not really within best practices to have a page start with three inline videos auto playing. If you did this on the web it would slow the download of the page due to the fact that the videos have to all download before the page opens. I would think that something like this has to happen on your App page as well. Then we have to think, does our viewer really need to see three videos starting at the same time?  It might be a cool effect, but is that really the most way to get a design point across?

Shawn Walker 0 votes