Post

9 followers Follow
2
Avatar

Help, big problems after upgrade from 3.2 to 4.0

I've just upgraded from 3.2 to 4.0 and stumbled upon different problems with the magazine I'm designing. I'm really shoked up about it because I have a couple of months work in it and dont want that to go down the drain.

This is what I'm encountering:

  • popup video's wont show in popup modus, they start playing directly in fullscreen modus

  • objects that are snapped to the innertopin the A layer, stay snapped and vissible even if you jumplink to other pages in the B layer

  • autostart video's sometimes wont autostart in preview

  • A video that use to start only on a peticular page also starts playing when you go to different pages

  • When I press a button you'll see a gray area that shows the invissible "clickable" area

I've tried publishing the Indesign documents with 4.0 settings butt that doesnt help.

 

Please help Mag+.

 

Chris

Chris Pelk Answered

Post is closed for comments.

26 comments

0
Avatar

i got similar problems:

-autostart doesnt work.

-the gray clickable area

-popup video doesnt work

please can you help us?

silvia roman ruiz 0 votes
0
Avatar

one more problem: when i play an inline video and i click to make it full screen it turns 180º !!!

silvia roman ruiz 0 votes
0
Avatar

I'm experiencing similar issues. Hope these issues are fixed soon--I've a presentation soon! thx for your assistance

Susan Shankin 0 votes
0
Avatar

Hi guys,

Thank you for all your help! Our developers have solved most of the bugs you have reported and hopefully it should work as it should now. Sorry for the trouble these errors have caused you. We will submit an update of the Mag+ Reviewer app this week that should be available in the AppStore at the end of next week, this will be v. 4.0.2. Version 4.0.1 was released yesterday and also contained fixes for some of the bugs that you reported. All apps built in Mag+ Publish already contains all the bugfixes made for 4.0.2.

I've commented your findings below so you know what to expect of the 4.0.2 update:

  • Popup video's wont show in popup modus, they start playing directly in fullscreen modus - We are working on solving this bug. Hopefully we will have a fix soon.

  • Objects that are snapped to the innertopin the A layer, stay snapped and vissible even if you jumplink to other pages in the B layer - Fixed in the 4.0.2 update of the Reviewer that should be available in the Appstore during next week. Apps built in Mag+ Publish from today will have these fixes included.

  • Autostart video's sometimes wont autostart in preview - Should be __fixed in the 4.0.2 update of the Reviewer that should be available in the Appstore during next week. Apps built in Mag+ Publish from today will have these fixes included.

  • A video that use to start only on a peticular page also starts playing when you go to different pages -_ Should be _fixed in the 4.0.2 update of the Reviewer that should be available in the Appstore during next week. Apps built in Mag+ Publish from today will have these fixes included.

  • When I press a button you'll see a gray area that shows the invisible "clickable" area - This is not a bug, when you are building your final app in Mag+ Publish you can choose to remove this effect. 

  • Also control image's seem to be vannished??? - This should be fixed in the 4.0.1 update released yesterday.

  • When i play an inline video and i click to make it full screen it turns 180º !!! - We haven't been able to reproduce this error, is it possible for you to send us the mib please?

Let me know if you found any other bugs and we will do our best to help you out!

Thank you,

Anders

Anders Odevik 0 votes
0
Avatar

Thats good news Anders.

Another bug I've found is that we can not use inline movies anymore. They dissapear or play only fullscreen.

And still control images are dissapearing (control type single)

 

Cheers,

Chris

Chris Pelk 0 votes
0
Avatar

Hi Susan,

 

You can find the version number when you click on the "about" button in the Mag+ Reviewer app.

 

Cheers,

Chris

Chris Pelk 0 votes
0
Avatar

@Chris: We will look at these problems! Thanks a lot!

@Susan: The update is available on the Appstore, click "Updates" and it should be there. Let me know if the problem persists!

//Anders

Anders Odevik 0 votes
0
Avatar

I am having a sight challenge with jump links with in the reviewer. 4.0.1 I designed the publication in 3.5 and have updated all the verticals when I check the whole issue things are a little hinky. 

  1. Out of 17 audio files only 7 files are displaying in the pull down window yet all the audio files work.

2.TOC links are are linking to the B layer verticals but not to the A layer verticals (Major Problem) A layer is does not move

  1. All of the previous jump links are taking me to destination within the vertical that were not set by me or just dont work at all.
Jessica Brant 0 votes
0
Avatar

I think I figured out the Jump Links Chalenge it seems that you have to have the B layer names with the object id as before but now you have to name the a layer with the object id. The challenge I have now is getting the A layer to pin properly Example:

One Vertical has 4 pages. On the fist page I have jump links that navigates to each individual vertical when clicked it takes you to the proper vertical on the B - Slides - main content and to the proper A but the content on the A - Main Tower - for inline body content jumps past the designated Snap point and I have tried the 3 different options outter-top inner top and top(using the invisible box trick that worked in 3.5 but are not working now. They all give me the same results content snapping past the desired point. 

As far as the jump links they work but not giving me the desired effect as before I have re done the links that seemed to fix things not going to the desired vertical. Now it is just getting the A layer to pin to the right place. You help is sooooooo needed 

Jessica Brant 0 votes
0
Avatar

Hi Mike,

Did the MIB I've send help a bit with solving the bugs, hope so :)

Any news  about update 4.0.2 that should be available this week?

I've got a big presentation tomorrow and really would like to show them a demo without bugs.

 

Cheers,

Chris

Chris Pelk 0 votes
0
Avatar

Hello, 

Does mag+ version 3.2 no longer work? For some reaons one of our titles that is still using that version can no longer do review or export files. They have a deadline tomorrow so was planning to help them upgrade to 4.0 after that, but no it seems we have no choice but to do it now? Any way of making 3.2 continue to work? 

Thanks in advance!

/Jenny

jenny.levallius 0 votes
0
Avatar

@Chris - Video media in popup works in builds from Publish as of now, will be part of 4.0.3 of the Mag+ Reviewer. 4.0.2 is still waiting for review by Apple, no date can be promised for Apple's review.

@Jessica - The A-layer not offlowing the B-layer works in builds from Publish as of now, is part of the 4.0.2 of the Mag+ Reviewer. The Playlist only display audio media explicitly marked as "Include in playlist". Apps build before 2012-10-08 with links to remote streaming audio may display without titles in Playlist.

Fredrik Gadnell 0 votes
0
Avatar

@Fredrik Olsson Thanks for getting back to me I have the A-layer not off flowing the B-layer with the Audio ticked to 'include in playlist" but the list are still not there. Is there anything I can do in the back end to change this?

Jessica Brant 0 votes
0
Avatar

@Jessica: Can you provide a screenshot that show the issue, if you have befor and after pics with 3.2 and 4.0 it's even better. And a MIB small file to test.

Fredrik Gadnell 0 votes
0
Avatar

@Fredrik Olsson here is an image shot of the playlist for the 4.0 version I trashed the 3.2 version so I do not have that to send you. I am including a mib it is a vertical that has 4 pages with audio files attached to each page. In this file 4 out of the 4 audios display in the play list. As I mentioned before I have 17 audios only 7 are displaying in te play list.

Thank You for your attention to this matter 

Jessica 

 

Jessica Brant 0 votes
0
Avatar

@Fredrik Olsson I forgot to add that I have looked in the vertical.xml file and the Media file states as follows for the audios (of course the name.mp3 or name.wav file name changes) 

<media mediaid="m8805" mediatype="3" x="-2" y="-2" height="30" width="38" src="pink-3.mp3" add-to-playlist="1"/>

<clickable\_area x="-42" y="-83" height="169" width="192" url="media://m8805"/> 

Jessica Brant 0 votes
0
Avatar

@Jessica - The files showing up are the mp3-files with meta-data, the empty ones are wav-files, that do not have such meta data.

I have updated so if you rebuild in Publish now, it will use the file name as the base for the track name if no meta data can be found.

As a general rule of thumb you should use m4a or mp3 audio files when possible (Technically AAC, ALEC, HE-AAC, and MPEG-1 layer 3 codecs). These formats support full meta data for title, artist, and duration. And as a bonus all iOS devices have hardware acceleration for playback, this reduces battery consumption and can frees up the CPU to update the screen instead of decoding audio, which can give better frame rates.

Fredrik Gadnell 0 votes
0
Avatar

@Frank,

Thank you for your help. I am converting all the files now to MP3 and adding meta data to them now. You are the bomb.... and Thank you once again. 

Jessica Brant 0 votes
0
Avatar

Even with latest 4.0.2 update (CS6) I'm still experiencing the following problems....

Control Images Issue: On/Off type for video control swap image.1 with image.2 correctly the first time but it won't change back to image.1 when video is in pause.

Jump Links: link to top of the vertical show ( I've try all options:  /  ;  //objectID ; /verticalID ;  /verticalID/objectID . I've even try naming the ID of verticals and objects with underscore.... no luck. Every time I jump from a link on the second page of a vertical to the top of the same vertical it shows the the bottom of the A layer of page 1 not the default top of the vertical.

Is it only me or version 3.5 was much more stable? 

best

marco

Marco Moretti 0 votes
0
Avatar

@Marco - Could you attach a MIB file where the jump links do not work as expected?

Fredrik Gadnell 0 votes
0
Avatar

hello Fredrik, thanks in advance

I've attached here a test .mib that reproduce the issues I spoke about....

regarding the jump link issue: in the first vertical you see a large image with on top 2 links

the red one will take you to the top of the second page in the same vertical, and the white link to its right will bring up the A Layer in the same page...

the problem is reveal when I try to go back to the top of the Vertical from the second page rather its stops at the bottom of the A layer on page 1 ... I have tried all options (see the 3 hotspots on top of page 2)

the second vertical reproduce the issue I'm having with Control Images ON /OFF...** play** change to pause but pause do not change back to play

thanks again for looking into this

Marco Moretti 0 votes
0
Avatar

@Marco - Excellent test MIB, and nice design as well.

Tapping the edges is supposed to navigate one screenful in that direction. This navigation area incorrectly took precedence over your link on the second page. This is now corrected if you rebuild in Publish. Interactive content is now correctly prioritized in this order:

  1. Bookmark toggle area.
  2. Link areas in design.
  3. Navigation borders.

The control image on the second vertical only updated on media full stop, not pause. This is also correct if rebuilt in Publish as of now.

These changes will be incorporated in next version on Mag+ Reviewer ASAP.

Thanks for your help Marco.

Fredrik Gadnell 0 votes