Post

4 followers Follow
0
Avatar

Uploaded mib says invalid in publish - Urgent...

We have wasted the last 2 days trying to upload mibs to publish - we are uploading an iPad 1-2 and a retina. The retina one uploaded fine, but the iPad 1-2 just says 'invalid' after waiting 8 hours for each attempted upload. 

'invalid' - any chance you can be more helpful? What is meant by "invalid"?

The file should be fine .... where do we even start? "invalid"  there must be some way to get more verbose interaction please. Its like saying "bad" or "wrong" .... we need to know more. 

David Wright Answered

Please sign in to leave a comment.

23 comments

0
Avatar

Hi David,

If you click on history you will be able to see all the mibs that have been uploaded. The problem with yours was "Errors: Mib file type does not match selected mib type."

Make sure that none of the verticals are exported as retina. The easiest way to do this is to look at the issue in a standard iPad and then check if a vertical is blank, that one is probably exported as retina.

Regards,

Anders 

Anders Odevik 0 votes
0
Avatar

there was nothing wrong with the mib as far as we could see. We found that is we closed publish down and then re-opened it in between Retina and standard build and then uploaded and that went up. 

David Wright 0 votes
0
Avatar

Hello, we have been experiencing the same issue and now tried to upload MIBs and they have been processing for over 14 hours, is there anyway we can reset the system or clear them.

g 0 votes
0
Avatar

@g: I had a look at your Publish account now and the files looks fine, we are sorry for your toruble with the uploading. All you need to do now is to upload store and newsstand images for the unpublished issues and you are good to go.

Cheers,

Anders 

Anders Odevik 0 votes
0
Avatar

I'm having the same problem.. I don't understand.... what do I do ?? i keep getting both my files rejected...

sidenote: what's the purpose of exporting the verticals in universal.. is there somewhere I can use that ? or just upload the retina and leave the regular iPad field alone ?? 

Christian Gomez 0 votes
-1
Avatar

Hi Chrisitan,

I had a look at your Publish account and noticed that the latest mib you tried uploading as an iPad mib was actually exported as an Android MIb from the production tool which is why the system don't allow it. You will need to have an iPad mib in order to upload for iPad.

Reagrding the universal mib setting, it is used when creating the help mib: http://support.magplus.com/entries/21357973

Regards,

Anders 

Anders Odevik -1 votes
0
Avatar

Obviously, I tried uploading the android by clicking the android button (and not the iPad).. but the system, once uploaded, always assumes It was an ipad... same problem as when I try to upload a retina.. the system always forgets the button I picked, changes it and decides I was trying to upload a new iPad version of the issue..

 

I've had this problem all weekend long.. can you dig deeper please

Christian Gomez 0 votes
0
Avatar

Very strange, I saw that you were able to upload the mib file now. I'm sorry for your trouble uploading, please let us know if it happens again!

Regards,

Anders 

Anders Odevik 0 votes
0
Avatar

Having the same issues! I tried reloading the Retinia file (that worked before) and it came up invalid... Please help!!

Tom Walzem 0 votes
0
Avatar

Are you hosting it elsewhere ? The problem on my end was solved when I figured out that all mibs need tobe in the same folder, inside of the server.. Hope this solves your problem ;)

Christian Gomez 0 votes
0
Avatar

Thanks for the reply Christian! I am hosting them with Mag+ it seems like the system is expecting a different format. Saying it was expecting the Retinia version... I am baffled. 

Tom Walzem 0 votes
0
Avatar

Hi Tom,

If you click "Edit" next to the issue in Publish and then click on "History" you will be able to see why the mib wasn't uploaded. In most cases this is due to the GUID verification, please read this article for more information: http://support.magplus.com/entries/21958901 ("Add issue content")

Regards,

Anders 

Anders Odevik 0 votes
0
Avatar

This is upload hell - we are trying to update our app and the same thing as the original uploads. We upload, it rejects, we upload it reject, we upload it rejects. We lose sleep for days on this each time. 

Currently the same - rejected. Please fix this area of the uploader. Its an ipad version, its guid correctly - the system says no. Extremely unfriendly months later. 

David Wright 0 votes
0
Avatar

I was able to fix any issue with this by 1- making sure the GUID is correct as Anders has said.. and 2- making sure that my uploads were located in the same folder  other than that the only issue I had since I figured out the server thing is a mistake I hadn't seen, a low res vertical had snuck into the retina version and production tool was confused.. Now when we upload it works.. David, are you self hosting the issues or mag plus ? check to make sure they are in the same folder on your server if you're hosting

Christian Gomez 0 votes
0
Avatar

Hi Christian, had 5-6 GUIDs stating they are wrong now. Hosting with MagPlus. No low res verticles. Its only the standard Ipad one again ( same as last time ) 

David Wright 0 votes
0
Avatar

I had that once... my solution was to open a new issue - start from scratch, in the publish - and start with that iPad... exact same issue I had. That fixed it.. no idea why though... hopefully it'll work for you.. IT IS SO FRUSTRATING.. thoughts with you :)

Christian Gomez 0 votes
0
Avatar

By the way.. if you upload to a server you can test each invalid much quicker.. as you don't have to upload each time the file.. you just paste the link in the box... it saved me a few hours easy... (i was able to try different scenarios.. uploading android first, or ipad 3 first.. without uploading the actual file)..

Christian Gomez 0 votes
0
Avatar

SURELY - THERE HAS TO BE A BETTER WAY!!!!!!! WE UPLOAD, IT ERRORS, WE UPLOAD IT ERRORS..........this is RIDICULOUS  Cant you check the filename BEFORE upload so that we dont wast relentless day after day after day? 

Its SUPPOSED TO BE A SIMPLE app update, make a tweak and update the files......and days later it STILL wont upload.......................  ipad 3 goes up straight up, no problem.  but ipad just fails and fails and fails, alway invalid GUID. 

our Client is furious and upset, and its all ugly, name error, name error, name error, name error, name error, name error, name error, name error, name error, name error    WTF!!!!!!!!!!!!!!!!!  We need SLEEEEPPPP.  How can you use this system........  still here at 4:30am in the morning AGAIN!!!!! Error Errror Errror.......

David Wright 0 votes
0
Avatar

Hi David,

I've sent you a PM, please reply there. The upload error happens because the GUID doesn't match the mib files that were uploaded before.

Regards,

Anders 

Anders Odevik 0 votes
0
Avatar

ok - we are trying this - it will take 4 hours or so to see how it goes. the updateing to your server from AU is very slow. Thanks for the help. We are confused that its asking for that GUID, but we will try that. 

David Wright 0 votes
0
Avatar

Thanks Anders - saved our sanity. Can the system PLEASE be adjusted to check a name PRIOR to uploading the file. It would make for a quicker process. 

Whats odd is that the original file we were updating was named as we were putting the GUID, but it wanted a new name. Wouldnt have been as much of an issue accept we were trying to match the previous issue name ( with the higher numbered extension ) If it works with a different name then so be it.

David Wright 0 votes