Post

1 follower Follow
0
Avatar

What could be causing "no b-layer" output to produce a black page?

Hi, We're testing your tools and  I'm using the 3.0 Plug and exporting 3.00 MIB files. When I export with "No B-layer", my page produces a black background and images are only seen. I was expecting to disable the b-layer on the double tap. Would you know what's happening? The page is pretty simple with everything on the A-Layer. Attached are my screen shots. 

Filename: no-b layer select.png is what it looks like when "no b-layer" is select. 

Filename: howitshouldlook.png is what want with the double tap b layer disabled. 

 

Thank you!

Nancy Jonathans Answered

Please sign in to leave a comment.

4 comments

0
Avatar

Hi Nancy, 

Make sure you have a white background block on the A-layer, that covers the entire page area, and the length of your vertical. Make sure to group all your elements, otherwise some might disappear behind the background. Also I assume that since you are doing it without a B-layer that you are designing for one, specific orientation. So make sure that you set the orientation of your vertical to the wanted orientation (landscape or portrait).

Best regards

Sara

Mag+ Support Team

Sara C Glaser 0 votes
Comment actions Permalink
0
Avatar

Hi Sara, 

Thank you for your quick answer. ( It's odd to have to add a white box behind the a-layer.) One clarification regarding the comment about  B-layer affecting orientation: we're building the pages all on the a-layer and designing for both orientations, is that correct? Also, the reason for exporting without the b-layer is to turn-off the blank page on the double tap. Could you confirm that this is the correct way to turn off the blank page on the double tap? 

 

Thank you, 

Nancy 

Nancy Jonathans 0 votes
Comment actions Permalink
0
Avatar

Hi Nancy, 

The idea with the tool from the beginning was to have the background images on the B-layer and to have the possibility to swipe the text, so that you could use the screen for as much image as possible, but still have the possibility to have a longer text.

Therefore you need to add a background image (on the B-layer or A-Layer if you're only using that). The Indesign white background is never included, instead the tool reads it as there is no background, and the iPad background i black, hence not seeing black text.

Since you are only using the A-layer, you can't use the pinning options that you have on the B-layer, so when you're designing your layout, it all has to be in the safe area. That means that your content can't use the full width of landscape (that would crop content in portrait) and can't be placed all the way at the top of the InDesign template, that would crop the content when going to landscape. I've attached an image of the Mag+ InDesign Template that shows where the content will be seen both in landscape and portrait.

You are right that this is the only way to 'turn off' the double tap. We haven't developed that functionality yet, but we are adding it as a feature request. so the only way not to have it, is to not use both the A and B layer.

 

Best regards,

Sara, Mag+ Support Team

Sara C Glaser 0 votes
Comment actions Permalink