CS5 + Windows 8 not supported

As Windows 8 does not officially support CS5 we are not able to promise that the Mag+ plugin will function properly with that combination of OS and CS version. 

This is referenced here in Adobe's support.

Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk